Talk:Installation

From Tango Desktop Project
Jump to: navigation, search

ImageMagick

"configure: error: ImageMagick is required to build tango-icon-theme"

The odd thing is that I have ImageMagick installed---is there a specific version or plugin that I need?

Edit: nevermind, I got it! Sykil 15:40, 17 December 2005 (PST)

Edit: If you haven't figured out what he (Sykil) did, he installed ImageMagick-devel. g/l!

Can't get "icon-name-mapping" to work

It fails when I run "make install" on the tango theme so I tried it manually and get the same odd error:

[root@localhost 16x16]# /usr/libexec/icon-name-mapping -c actions

501 Protocol scheme 'file' is not supported file:/usr/share/icon-naming-utils/legacy-icon-mapping.dtd Handler couldn't resolve external entity at line 2, column 50, byte 73 error in processing external entity reference at line 2, column 50, byte 73 at /usr/local/lib/perl5/site_perl/5.8.1/i586-linux-thread-multi/XML/Parser.pm line 187 [root@localhost 16x16]#

Note that there is no file:

/usr/share/icon-naming-utils/legacy-icon-mapping.dtd

in that location, it is installed as:

/usr/share/dtds/legacy-icon-mapping.dtd

adding a copy in the other location doesn't fix the problem.

./configure fails :(

For some reason I can't install Tango Icon Theme on my Gentoo :(

This was for 0.6.2 release. From 0.6.6 I can Tango on my Gentoo ;)

Install on Slackware?

Hello! I've been trying to install your lovely icon theme in Slackware.

I installed XML::Simple, then icon-naming-utils from source using configure , make , checkinstall . When I did tango-icon-theme-0.7.2/configure , I got this error message:

configure: error: icon-naming-utils >= 0.7.2 is required to build and install tango-icon-theme

I'm sure it's just a simple matter of using icon-naming-utils-0.7.2/configure --prefix=/path/to/foo . I need to know how to get tango-icon-theme-0.7.2/configure to recognize that icon-naming-utils is installed.

BTW: I'm using (Slackware's) KDE 3.5.3 as my desktop, on Slackware -current.

Feel free to e-mail me, and thanks in advance.

Install on Debian sarge (2.6.8)

I get the same errormessage as the Slackwaredude above, and I just can't figure out how to make this work. I've tried installation of icon-naming-utils with both apt-get, and by compiling myself. Installation goes without any trouble, but it doesn't seem to be registered properly on my system because the tango-icon-theme fails on configure.


Solution: pkg-configure was not version 0.19 or above! ;) Upgraded from unstable release, and then it worked perfectly